Wednesday, August 15, 2012

v4 Linaro armhf image for mk802


Just a quick post - I've updated my Linaro/ALIP/armhf image for the MK802 device.

Compared to the first version, this one is based on Linaro 12.07 instead of 12.06; has a Mali X11 driver; has various filesystem optimisations that improve performance a bit; has more drivers for stuff compiled into the kernel.

Compared to the second and third versions, it has more drivers for stuff, and some X11 problems were fixed.

Download from: http://dl.miniand.com/toby_corkindale/linaro-alip-armhf-t4.7z

31 comments:

  1. Hey! Great stuff toby! Got my tablet to work somewhat..

    Erm. . When I open more than one app, the screen gets splotched with horizontal multicolored lines..
    And then hangs..

    What could be wrong?
    mali driver unstable? Is the screen freq. detected wrongly, . how can one compare this with the framebuffer enabled instead of the mali gpu ?

    ReplyDelete
    Replies
    1. The same happened for me in some distributions. I don't know, if this release is build for 1024M memory too, but since I have 512M, I had to use this http://rikomagic.co.uk/forum/viewtopic.php?f=2&t=90&start=20#p480 to get rid of those colored lines on screen.
      Tomas

      Delete
    2. Hola,
      Hey tomas, thanks bro.. yeah what a DOh! My tablet works fine with the 512 Mb uboot.

      Way ta go Toby! :)

      Delete
  2. I really don't know what is going on there. My setup is on an A10-based HDMI device, not a tablet, so maybe there are some differences between it and your hardware?
    I suggest you run memtester a bit, check that you don't have some faulty memory blocks.
    To disable the Mali X11 driver, just rename /etc/X11/xorg.conf to something else and reboot.

    ReplyDelete
  3. Hi Toby, I really appreciate your work done on this system.

    I'm having an issue though. I've installed the 12.07 image and I'm stuck at the Authentication window for the NetworkManager (trying to enter my Wifi details) and I'm not sure what password to use or how to fix it. I've searched around for a solution/password but to no avail. I haven't noticed anyone else with a similar problem so I'm not sure what I'm doing wrong?

    ReplyDelete
  4. Hi Wardy,
    Have you tried using the default linaro user's password? (linaro)

    ReplyDelete
    Replies
    1. Thanks, I should have tried that.

      I'm also experiencing the no sound issue that Christopher mentioned.

      Delete
  5. Hi Toby!

    I booted my mk802 1gb with your image but unfortunately no sound at all... alsamixer shows that everything is ok.

    Any ideas?

    ReplyDelete
    Replies
    1. I use this ~/.asoundrc:

      pcm.dmixer {
      type dmix
      ipc_key 1024
      ipc_key_add_uid false
      ipc_perm 0660
      slave {
      pcm "hw:1,0"
      rate 48000
      channels 2
      period_time 0
      period_size 1024
      buffer_time 0
      buffer_size 4096
      }
      }

      pcm.!default {
      type plug
      slave.pcm "dmixer"
      }

      pcm.!hdmi-remap {
      type asym
      playback.pcm {
      type plug
      slave.pcm "remap-surround71"
      }
      }

      pcm.!remap-surround71 {
      type route
      slave.pcm "hw:1,0"
      ttable {
      0.0= 1
      1.1= 1
      2.4= 1
      3.5= 1
      4.2= 1
      5.3= 1
      6.6= 1
      7.7= 1
      }
      }

      Delete
    2. This comment has been removed by the author.

      Delete
    3. Thanks Lajos!
      That did the trick.
      Has anybody managed to play a movie in lubuntu/linaro yet?
      I think that without 3d mali linux support all this images are not ready yet to go mainstream.Android on the other hand is "flying" on MK802.
      Am i missing something?

      Delete
    4. Thanks, audio now works for me also.

      Delete
  6. Great job! Works much faster than other images I tried, however there is some problem with wireless. First time I booted it work, but now it doesn't see wireless adapter anymore. iwconfig shows no wireless interfaces. How it can be fixed? Also is there an option to connect working mk802 to PC's usb in mass storage mode? Actually it doesn't work for me in android but I wondering if it can be done from linux?

    ReplyDelete
  7. hey toby,

    i´m using your linaro build on my new mk802 II and it´s really great and useable. but i would love to switch to german, but don´t know how and can´t find anything about it with google. i changed the language of the gentoo system on my atrix with some editing and terminal stuff. is the procedure maybe the same or similar? sorry, i´m a little linux noob but willing to learn...
    ;p

    ReplyDelete
  8. Heya toby,

    And how've you been doing? :)

    I have some wifi issues and have outlined the issue at:
    https://www.miniand.com/forums/forums/development/topics/wifi-problem-while-using-lubuntu?page=1#post-2865

    Basically, wifi shows access points but doesnt connect -> no ping packets get sent across...:( Is that a hardware thing?

    ReplyDelete
    Replies
    1. Heys, got stuff sorted out! I had to configure etc/network/interfaces with a

      pre-up ifconfig wlan0 hw ether [my:mac:addr:ess] up || true

      and then iwconfig wlan0 essid "NetworkName"...

      Cheers!

      Delete
  9. hi, any update available concerning the mail x11 stuff.
    3d acceleration still not possible.

    thanks, maik

    ReplyDelete
  10. I've been out of the country for the past several weeks, and won't return for another couple. I see there's been some work done on the DRM API though, so it's possible we may have some 3D accel.

    ReplyDelete
  11. I'm typing this on my 1G MK802 (version 1) and it works very well. No more video glitches.

    There seem to be some stability problems. From time to time, the screen will go black for a second and I'll be back to the login screen. I believe this means that X crashed. This happened 3 times in about 3 hours. I was using either synaptic or firefox at the time.

    The stability problems mean that I can't use the MK802 for real work at the moment, but it remains an interesting hobby machine. I'm looking forward to future versions of the OS.

    ReplyDelete
  12. This comment has been removed by the author.

    ReplyDelete
  13. Hi Toby, i'm running this img on my MK802II by 8gb(sandisk class 4) !! It's just perfect!! It's powered from yesterday morning and I haven't noticed problems!! I'm testing it running a "c infinite while" and doing in the same time normal operation like web surfing or text editing(and writing this post, by the way sorry for my english :D) etc etc... no problem!! I've install JDownloader to see how it work with jvm and again no problem!! I hope that Mali driver will be released/hacked soon :D... thank you for this great img!!

    ReplyDelete
  14. Hello Toby,
    Thank you for this great and stable linaro version for the mk802.
    Based on the T4, I would like to recompile the kernel. Which .config did you use ?
    Best regards

    ReplyDelete
    Replies
    1. I've managed to configure my MK802 II device to work as a server with linaro Linux and kernel 3.0.36-t3.
      It was a lot of work to compile all necessary modules into kernel to support IPV6, full iptables, ppp(needed for 3G and ppoe connection) and other modules needed for a vpn server.
      The original kernel has just a few modules for mk802 to be used as a desktop.
      I use it as a VPN(pptpd) server for now. Also I've installed apache and php for future projects.
      If someone want to see more details about system info can visit http://serox21.no-ip.org

      Also I can provide .config file for kernel compilation or compiled kernel and modules if you are still interested

      Delete
  15. Toby, haven't seen you active in awhile. You were doing a lot of good work with the A10. There are new developments, XBMC is running with hardware acceleration, its got a lot of people excited.

    Also we have a project to offer pre-installed Linux on Allwinner tablets and devices, the PengPod, http://www.pengpod.com. Also we have pre-orders available on http://www.indiegogo.com/pengpod. The devices will support XBMC with hardware decoding, Plasma active and more right out of the box.

    I hope you will help spread the word.

    ReplyDelete
  16. I've just installed into my minix plus (512M), and with apt-get update + upgrade is going fine, much more than the other based on 12.06.

    Thank you very much!!!

    ReplyDelete
  17. This ALIP for A10 runs extremely fast, boot time is 10s and it's extremely responsive. I was a bit amazed.

    BTW, I'm using Uhost, not mk802, and wifi wouldn't start (on the Uhost the 8912cu is on a usb port, not sdio). I copied script.bin from my device and Linaro wouldn't boot. I had to merge my UHost script.bin with the evb.bin in the image, using bin2fex and fex2bin. Works flawlessly.

    ReplyDelete
  18. how ca I run linaro in console mode without X server?
    Init 3 should be the srat mode in rpm based linux versions?

    ReplyDelete
    Replies
    1. interested in this as well ... bot found a solution (and I do not think runlevel 3 makes sense anymore in ubuntu/linaro ...)

      where is my inittab :-) ???

      tom

      Delete
    2. Ah, maybe you'd be interested in one of the later A10 images I've built? I made one in particular recently that's aimed at being a headless install for server/embedded hardware purposes.

      Delete
  19. Toby,
    I'm trying to run this in qemu so I can do some arm compiling and run the software on the target platform. I see 3 files, 0.img, 1.img, and 2. I'm hoping these are the kernel and initrd but I'm not sure. Any advice?

    ReplyDelete
    Replies
    1. Hi Taylor, I'm pretty confused and am not sure what you're looking at.. The file above decompresses into one big binary image for an SD card, plus some instructions for how to install it to the SD card.
      If you're interested in dev, I suggest looking at a more recent release from me, as those include the necessary qemu bits to allow an emulated chroot from an intel machine easily, making it trivial to develop on.

      Delete